Remko Weijnen's Blog (Remko's Blog)

About Virtualization, VDI, SBC, Application Compatibility and anything else I feel like

Archive for the ‘General’ Category

Fixing Applications: The Next Step

Lately I wrote a few articles about fixing bad applications using Compatibility Shims. If you didn’t read them yet, here are the links: 

I also described that you can install an Application Compatibility Database using the sdbinst command.

At first I just took a script task in my Altiris Server to deploy the database using sdbinst -q <dbname> but later on I got a better idea.


Paging file and Memory Dump

I often hear that people configure the Paging File (on Citrix or Terminal Servers) on a seperate volume but, the reasons is either performance or the chance that the Paging File might corrupt the volume.

However if at some point you would like to create a Memory Dump you must have a paging file on the boot volume.

For a Small memory dump you need at least 2MB Paging File on the Boot Volume but for a Full Memory Dump you need a Paging File that is sufficient to hold all the physical RAM plus 1 megabyte (MB).

Side Note: with the increasing ram of today’s servers, how long does it take for a full memory dump to be saved when you have lots of gigabytes?

See also: Overview of memory dump file options for Windows Vista, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows XP, and Windows 2000.

Today I wanted to install the Dutch Language pack for Internet Explorer 8, the Dutch language comes as part of the Windows Internet Explorer 8 MUI Pack (in my case the version for Windows Server 2003 SP2).

If you install the MUI Pack you will always end up with all 35 (!) languages installed. This behaviour is the same as the language pack for Internet Explorer 7 that I wrote about earlier (see Modifying Microsoft Updates and/or hotfixes)

The solution is really the same as for the IE7 language pack: you modify the inf file (in my case update_srv03.inf) but if you run update.exe it will refuse to use your modified inf file:


So we need to patch update.exe to accept your modified version!


WordPress monthly archives broken

I noticed that the monthly archives on my blog were not working. I first thought it was a problem with the .htaccess file but it was correct.

I also tried resetting the permalinks option in WordPress to default an back but that did help as well.

After some digging I was able to fix it by selecting an option in the Robots Meta plugin I use:


I selected the Disable the date-based archives option, saved settings and de-selected it again. I am not sure what it changes (the .htaccess file was not changed) nor did I check the code to see what it does but at least it’s working again!

  • Filed under: General
  • My favorite KB Article

    The previous post reminded me of my all time favourite knowledge base article from Compaq titled: “Where do I find the “Any” key on my keyboard?

    It’s still in

  • Filed under: General
  • Script to register ASP.NET in IIS

    I did an unattended install of the Citrix WebInterface on a testmachine and it failed with error 258.

    The logfile clearly indicates the reason:

    [ ERROR ] com.citrix.wi.install.SetupErrorReporter: Error 258 occurred: ASP.NET 2.0 must be registered and enabled in Microsoft Internet Information Services before the Web Interface can be installed.

    We can register ASP.NET in IIS with the Aspnet_regiis.exe tool that comes with the .NET framework.

    The commandline would be:

    aspnet_regiis.exe -enable -ir

    We do need to make sure we are using the proper version of the tool (x86 or x64), I did that in the Embedded Altiris Script:

    Related Articles:

    This means you are installing the wrong edition, eg x86 version on an x64 OS.

    All available version are listed on the MSDN Visual J# Redistributable Packages page.

    Related: The case of the VMware vSphere Client

    Disabling Java Autoupdate

    I did an unattended install of Java Jre1.6_0.22 using an mst file that puts all (auto)update properties to off.

    However it seems that Java simply ignores this, so usually a script runs after the install to the delete some registry keys and perform some extra configuration.

    With more recent Java versions it’s easier to simply uninstall the update component with the following commandline:

    msiexec /x {4A03706F-666A-4037-7777-5F2748764D10} /qb-

    I recently bought a new router, a Netgear WNDR3700 and I noticed a silly bug. When you make a DHCP reservation in the webinterface it will present a list of existing clients which makes it easy to add them to the reservation list.


    This seems to work fine at first but when I checked my IP with IPConfig I noticed that I received a different address. I checked the router’s log and saw this:

    [DHCP IP:] to MAC address 00:21:5c:9a:a0:99, Thursday, September 23,2010 14:03:59

    I noticed that the MAC address was lowercase here and not uppercase as in the webinterface. I changed the case in the webinterface and then it worked fine!


  • Filed under: General
  • The poor man’s e-mail archiving solution

    My work e-mailbox is hosted on an Exchange server and is very limited in size (only 100 MB) so I use a PST file to archive mail when it’s full. This has of course several disadvantages such as possible corruption on the PST and some limitations. I open my mailbox from severals places: Outlook on my laptop, Outlook Web Access remote (no PST available in OWA), Outlook from my Virtual Desktop (no PST since it’s located on my laptop) and so on.

    Then I got the idea to create a seperate GMail account and use that for archiving. I added the new account as IMAP mailbox in Outlook and create some folders & subfolders in it:



  • Filed under: General
  • Donate