Remko Weijnen's Blog (Remko's Blog)

About Virtualization, VDI, SBC, Application Compatibility and anything else I feel like

Archive for the ‘Oracle’ Category

Today I was asked to assist in troubleshooting an Oracle Client (10g) installation. The installation halted very quickly with a java.lang.NullPointerException:

 

(more…)

  • 0 Comments
  • Filed under: Java, Oracle
  • Another Oracle Error

    My collegue that is working with me on the current project was packaging another application that uses Oracle.

    The interesting thing about it is that he ran into the same error I did: the Oracle client tries to create (and access) an Object in the Global namespace.

    But he got an entirely different error message:

    OCIEnvCreate failed with return code -1 but error message text was not available

    To confirm it was the same issue I gave a test user the Create Global Objects privilege and after logging on again the problem went away.

    So I applied the same fix that I wrote about yesterday in Redirect Global Object to Local Objects (aka fix that bad app!) to this application and it worked nicely!

    Today I was working on Unattended Installation of an Application called SmartDocuments.

    The application seemed to behave nicely on a Multi User (Citrix/Terminal Server) environment: it writes user configuration to the user part of the registry and writes configuration files in a user accessible path.

    When testing with a normal user account I ran into a problem though, I got an Oracle ORA-01019 error message:

    ORA01019

    The English message is ORA01019: unable to allocate memory in the user side.

    (more…)

    Unattended Installation of the Oracle Client

    Last week I needed to an unattended installation of the Oracle Client, in my case version 10.2.0.1.0.

    Oracle has a record switch that allows you to record an installation and generate a response file using: setup -record -destinationFile response_file_name. This is documented here.

    When you are finished you can use this response file to perform the unattended install, eg setup -silent -responseFile response_file_name.

    There is a problem though, the installer (setup.exe) launches a java based installer and immediately returns.

    This was a problem for me since I cannot deploy a dependant application if the Oracle install hasn’t finished yet.

    I did some googling and found a lot of questions about this subject and saw a common resolution where a script is watching a certain file that is creating when the installation has finished in a loop.

    I figured there should be a better wait so I to a closer look at the installer with Ida Pro. I noticed that setup.exe launches another exe. called oui.exe (Oracle Universal Installer) which in turn launches Java.

    (more…)

    Donate


    Blogroll


    Categories


    Archives