Remko Weijnen's Blog (Remko's Blog)

About Virtualization, VDI, SBC, Application Compatibility and anything else I feel like

Archive for the ‘VMWare’ Category

Ubuntu crash when pasting files from VMware

It’s been a while since I last wrote a post but it does feel good so I’m expecting to pick up blogging in a more regular cadence soon!

This one is a quicky though, as I had an annoying issue with Ubuntu 22.04 VM’s running on VMware workstation.

Every time I attempted to paste a (larger) file from the host it would crash Ubuntu’s File Explorer (Nautilus):

Nautilus (Ubuntu's File Explorer) crashes when pasting a file from a VMware host

click video above to play

Fortunately I found a workaround:


  • Filed under: Linux, Ubuntu, VMWare
  • Google Earth fix for XenApp, RDSH & Horizon

    Google Earth LogoBoth Google Earth and Google Earth Enterprise do not work correctly for multiple users on shared Hosted Shared Desktops (I still prefer to call it Server Based Computing but that’s likely because I’m an oldtimer).

    Problem summary
    So let’s look at the actual issue: the first user on a server is able to launch Google Earth but for any subsequent users on the same server Google Earth fails silently.

    Problem details
    Google Earth uses various synchronization objects such as Events and Mutexes but registers those in the \Global namespace instead of the \Local namespace.



    Recently support for NPAPI has been removed from Google Chrome. While understandable from a security point of view it does mean that some plugins no longer work.

    A good example is VMware’s Client Integration Plugin where we’ve lost the ability to upload an ovf template. While VMware has published a fix for vCenter (see this kb), it has not been fixed for vCloud Director:

    The attempted operation cannot be performed using this browser. Re-try using an alternative method:

- Use the VMware OVF Tool to perform the operation. You can download the OVF Tool and its User Guide from the OVF Tool product page at
- Use a browser and platform combination that is supported by vCloud Director for this operation. For the supported browser and platform combinations, see the Release Notes for this version of vCloud Director.


    In versions prior to 6.0 VMware supplied the VCSA (vCenter Server Appliance) as an OVF template that could be imported directly.

    Starting with version 6.0 the installation process has changed and now consist of an .iso file containing a custom, HTML based, installer. Vladan Seget has a nice blog post where he describes the installation.

    This installation process is annoying, it needs a separate client (Windows) machine to run the installer on, requires the Client Integration Plugin (which doesn’t appear to run well on chrome now that support for npapi/dpapi has been removed):
    Please install the Client Integration Plugin 6.0 provided in the vCenter Server Appliance ISO image (requires quitting the browser)

    But even worse is that we cannot import VCSA 6.0 in vCloud Director. Even converting the OVF inside the iso file doesn’t help because vCloud directory lacks support for Deployment Options.


    Dumping passwords in a VMware .vmem file

    imageBenjamin Delpy the author of the well known mimikatz toolkit has released a very cool extension to WinDbg today.

    In summary the extension can extract Windows passwords from memory dumps, hibernation files and Virtual Machine .vmem files (paging, snapshots).

    Especially the ability to extract passwords from .vmem files was very interesting. So I decided to to test this out, so let’s see how it works!


  • Filed under: VMWare
  • For a research project I tried to install Windows NT 4 Terminal Server on VMWare Workstation (version 8).

    The setup would always fail however with the following error:

    Setup was unable to verify drive C:\ | Your computer may lack sufficient memory to carry out the verification, or your Windows Terminal Server CD-ROM may contain some corrupt files. | Press ENTER to continue

    Obviously the installation doesn’t really fail because of too little memory and neither is the installation disc (an iso file) corrupt, it’s a bug.


  • Filed under: VMWare
  • Virtualized Mac OS X Freezes

    Mac OS X Snow LeopardI am running a virtualized Mac OS X machine in my VMWare Workstation but I noticed that after a period of inactivity the virtual machine would sometimes freeze.

    Because this only happens after inactivity I assumed it had something to do with Power Saving so I changed the Energy Saver settings and that fixed it!


  • Filed under: Apple, VMWare
  • Deleting scheduled Altiris tasks from SQL

    I needed to delete around 50 scheduled tasks from several machines in Altiris because something went wrong in on of the first jobs.

    It would have better if the jobs were configured to fail on error and not continue but they weren’t.

    Deleting the jobs from the Altiris console is very, very, slow. First the console asks for confirmation (after showing the hourglass for a long time):


    Then the actual delete can take a few minutes and then the next server and so on.

    I decided to delete the tasks directly from SQL.

    I know this is not preferred but I think in the end it’s safe enough because I found a stored procedure called del_event_schedule which looks like this:

    So al it does is a (transacted) delete from the table.



  • 1 Comment
  • Filed under: SQL Server, VMWare
  • I was deploying virtualized Citrix XenApp Servers on HP BL460c G6 servers and somehow the storage (direct attached) responded very slowly.

    I had expected reduced performance (see my earlier post) since I didn’t have the  Battery Backed Write Cache module installed.
    I did order them but had to start deployment before they arrived.

    I did not however expect such an extreme bad performance. Deployment took ages or sometimes failed completely and when logging in to a VM it responded very sluggish.

    Disk Latency

    I looked in the vSphere console what the Disk Latency was. Latency under 10ms is usually considered good while a latency between 10 and 20ms is a potential performance problem.

    I was shocked to notice that the Disk Latency was much higher with peaks toward 2.000 ms (2 seconds!):




  • Filed under: Citrix, VMWare
  • Add VMXNET3 driver to Windows PE PXE Image

    After compiling the VMWare VMXNET3 Driver for Linux I needed a driver for the Windows PE Image as well.

    Compared to what I needed to do for Linux this was a breeze!

    First we need the VMWare tools again so I grabbed windows.iso from /vmimages/tools-isomages.

    The driver files are in a cab file,, extract this cab file somewhere and open the Altiris PXE Configuration tool.

    Select the Windows PE Entry and click Edit:image

    Then click Edit Boot Image:



  • 1 Comment
  • Filed under: Altiris, VMWare
  • Blogroll