Remko Weijnen's Blog (Remko's Blog)

About Virtualization, VDI, SBC, Application Compatibility and anything else I feel like

Archive for the ‘VMWare’ Category

I am currently provisioning a lot of Virtual Machines in VMWare vSphere 4.1. Because I had already sized the Virtual Machines I am doing this from PowerCLI based on my Excel Sheet.

I will probably blog later about the details of how I am doing this in PowerCLI (would you be interested in that?) but after successfully deploying some Windows 2008 VM’s I got this error in PowerShell:

New-VM : 3-11-2010 10:00:50 New-VM The operation for the entity VirtualMachine-vm-150 failed with the following message: “Cannot complete customization.”

At C:\Users\Administrator\Documents\NewVm.ps1:64 char:14

+ $VM = New-VM <<<< -Name $Name -VMHost $VMHost -Template $Template -OSCustomizationSpec $Spec -DiskStorageFormat $DiskFormat -Datastore $LargestDataStore

+ CategoryInfo : NotSpecified: (:) [New-VM], CustomizationFault

+ FullyQualifiedErrorId : Client20_TaskServiceImpl_CheckServerSideTaskUpdates_OperationFailed,VMware.VimAutomation.ViCore.Cmdlets.Commands.NewVM

In the vCenter console the following error was logged:

Cannot deploy template: Cannot complete customization.


  • Filed under: VMWare
  • The case of the VMware vSphere Client

    Today I connected with my laptop to VMWare Virtual Center using vSphere client. Because I had an older version of the client I needed to update and the installer failed with this message:

    The Microsoft Visual J# 2.0 Second Edition installer returned the error code '4113'

    I remembered this error from the last install of this client (about a year ago), it happens because Microsoft Visual J# was already installed (in my case it was previously installed by Embarcadero’s Rad Studio).

    Last year I “fixed” it by modifying the msi file but I remembered that Assarbad posted an easier solution on his Blog a while ago.

    His solution was to set a public property in the MSI (USING_VIM_INSTALLER) but it means we need to unpack the installer exe first to obtain the MSI file.

  • Filed under: Delphi, VMWare
  • Change Driveletter Commandline Tool

    Some time ago (2008 actually) I wrote a tool that can assign driveletters given a volumename. I use it myself after SysPrep operations to assign the desired drive letters. For instance after cloning a Virtual Machine from a template.

    I noticed that I updated this tool sometime after the original post but never uploaded it here. The most important changes are:


    I was trying to create a (very) large Datastore on VMWare vSphere 4.1 but although VMWare correctly identifies the LUN on my SAN it refuses to create the Datastore and gives me this error:

    Call HostDatastoreSystem.QueryVmfsDatastoreCreateOptions for object ha-datastoresystem on ESX failed.
    The complete error text is

    Call “HostDatastoreSystem.QueryVmfsDatastoreCreateOptions” for object “ha-datastoresystem” on ESX “<IP of ESX>” failed.


  • Filed under: VMWare
  • As you may have read I am currently implementing VMWare vSphere 4 on several HP Proliant DL380 G7 machines.

    I ran across an interesting knowledge base article from VMWare that describes a possible issue that is summarized as “Power on and storage operations are slow with the HP Smart Array P410i controller“.

    Essentially this just means a performance issue and the resolution is to install an extra (256 MB) cache module on the RAID controller.

    The Cache Module has HP article # 462968-B21 (not to be confused with 462969-B21 which is the Battery Kit).

    Google search on 462968-B21.

  • 1 Comment
  • Filed under: VMWare
  • I just installed my laptop with Windows 7 (x64) and I was curious how the new Windows XP mode worked (more on that topic later). After installing it I could no longer start any Virtual Machines in VMWare Workstation. The VM fired up but immediately halted with the following error: “VMware Workstation unrecoverable error: (vcpu-0)” “VCPU 0 RunVM failed: -2”.



  • 1 Comment
  • Filed under: VMWare, Windows 7
  • Blogroll